HWiNFO32 Intro

Welcome to HWiNFO32 !

HWiNFO32 is a professional system information tool, that supports latest technologies and standards. It allows you to examine the complete hardware configuration of your computer. It:

  • shows all hardware components hierarchically in a tree

  • displays status from hardware monitors

  • does benchmarks

  • creates various types of logfiles <registered version only>

This program is updated quite often in order to support the newest components. Be sure to check for the latest version at HWiNFO/HWiNFO32 homepage http://www.hwinfo.com.

HWiNFO32 is Shareware meaning, that you can freely download the shareware version and use it for you own purposes, but not longer that the 14-days Trial period. If you register, you can use the program legally after the evaluation period of for commercial purposes and HWiNFO32 enables advanced features like the ability to export a logfile. You can find more information about registration here.

Copyright (c)1999-2001 Martin Malík - REALiX
All rights reserved.


About Registration

Registration benefits:

  • You can use this program legally after the evaluation period and for commercial purposes
  • You won't be bothered with "Please register" messages
  • You can create a complete report file and export it (clink to see an example):
    • HWiNFO32 Text logfile
    • Comma-Delimited Report
    • XML Report (structure definition)

How to register:

If you would like to register HWiNFO32, there are the following options available:

Registration Method | How to register | Requires filled registration formular | Requires additional 10% of the sum
On-line registration using your credit card | Follow these links for a Commercial License or a Non-commercial License | N | Y
Wire transfer | The bank account number is available upon request. | Y | Only if the beneficiary takes the transfer costs
Send a check | Enclose a check payable to Martin Malik | Y | Y
Cash | Send money in bills at your own risk | Y | N

In all cases except the on-line registration it is required, that you fill the registration formular found on the next page and send to:

Martin Malík
Jakubovo nám. 3
811 09 Bratislava
SLOVAK REPUBLIC, EUROPE

If you’re sending a check or cash, please include the payment in that letter. If you’d like to send cash, please use a registered letter and don’t send coins. When registering using on-line or wire transfer, you can send the filled registration formular per e-mail to martin@hwinfo.com.

The Registration fee is:

License TYPE / User amount | Non-Commercial |  |  | Commercial
 | US$ | EUR | Sk/KC | US$ | EUR | Sk/KC
Single-User | 25 | 24 | 750 | 50 | 48 | 1500
2-10 Users | 20 | 19 | 600 | 40 | 38 | 1200
11-20 Users | 17 | 16 | 500 | 34 | 32 | 1000
21-50 Users | 13 | 12 | 400 | 26 | 24 | 800
51-100 Users | 10 | 10 | 300 | 20 | 20 | 600
UNLIMITED | Contact the author


Installation Progress

HWiNFO32 requires a kernel driver to be installed in order to access hardware. If you run the program for the first time it asks if you wish, that the program installs the driver automatically. Please choose YES. If you are running under Windows 9x/Me the installation/removal of such a driver requires the system to be restarted. Under Windows NT/2000/XP it isn't required, the driver will be installed automatically without the need of system reboot. If you upgrade to a newer version of HWiNFO32, which may require a newer driver it may happen, that the older driver is still installed in the system. In this case the program detects this need automatically and asks if you wish to install the new driver (this requires the removal of the old driver and install of the new one). This will be also performed automatically.

In case of some problems with driver installation, you can use the "Install HWiNFO32 Kernel Driver" tool to install the driver manually, however, this shouldn't happen:

There are two options available, from which is only one available depending on the current driver installation status:

  • Install new: Installs the driver into system
  • Remove: Removes the driver from system

If you're upgrading HWiNFO32 you should remove the currently installed driver and then install the new one. So you must run the driver installation tool (HW32inst.EXE) twice. You need to reinstall this driver only if you get a new version of HWiNFO32, which may include an updated version of driver, or if you change the HWiNFO32 destination folder.

Note: Installing any Kernel-mode driver under Windows NT/2000 requires Administrative privilegia. Once this driver has been installed, you can run HWiNFO32 under any account.
The automatic driver install/upgrade is available only in HWiNFO32 Version 1.03 and above.


New Page 1

List of requirements:

  1. Microsoft Windows XP or Windows 2000 or Windows NT (Windows 9X - limited)

  2. Local Administrative rights during installation of kernel driver

Explanation:

  • Required Operating System

Althrough HWiNFO32 is developed for Win32 subsystem, it is designed for NT technology, which means it achieves best results while running under Microsoft Windows NT 4.0, Windows 2000 or Windows XP. However, you can run HWiNFO32 under Microsoft Windows 9X, but some features may not be reported correctly and some components can't be found.

  • Other Requirements

The installation of a kernel driver requires local administrative rights. This is required only the first time the program (driver) is installed on a computer.

  • Operating System Limitations

Operating system | Unsupported features
Windows XP, 2000 | No known issues
Windows NT 4.0 | DDC Monitor identification, USB support
Windows Me, 98, 98SE | Video memory, RAMDAC, COM/LPT ports, PnP devs, MPS, Disk benchmark
Windows 95 | <Unsupported due to many issues>

Note: HWiNFO32 doesn't include a VxD driver for Windows 95, but the HWiNFO32.SYS driver can be used under Windows 98 too. If you'd like to run HWiNFO32 under Windows 9X, please choose Windows 98, because Windows 95 doesn't support NT drivers and HWiNFO32 can't access all hardware. Otherwise you may choose to use the DOS version of HWiNFO. You can find more info at: http://www.hwinfo.com


CPU Information

Processor Information:

  • Processor Name: Vendor, model and measured operating frequency of the CPU
  • CPU ID: CPU identification number. Each Intel Pentium, AMD-K5, Cyrix 5x86 and above CPUs contains this ID. It consists of:
    Type | 0, 1 (OverDrive), or 2 (Upgrade)
    Family | 4 = 486, 5 = 586, ...
    Model | 1 = Pentium, 8 = Pentium MMX
    Stepping | Varies
  • CPU Vendor: Contains the vendor string stored in CPU (generally this is "GenuineIntel" for Intel, "AuthenticAMD" for AMD, etc...)
  • CPU Stepping: During the life-time of a CPU model, it is common, that the vendor locates some minor errata or mades minor changes to the CPU. These versions can be identified using the CPU Stepping (e.g. kB0, kC0)...
  • CPU Type: Not used for later CPUs. Can be: Original OEM Processor / OverDrive / Upgrade
  • Processor Number: Available only for Intel Pentium III CPUs and only if this feature isn't disabled. This is an unique serial number for each CPU.
  • Current Clock Ratio: The CPU clock multiplier (OperatingFrequency = FSB * ClockRatio). Later CPUs may have this clock doubled (Athlon/Duron) or quadripled (Pentium 4). This ratio is available on for Intel Pentium Pro, AMD K6, Cyrix 5x86 and later CPUs.
  • Current FSB Clock: Front Side Bus clock measured from CPU operating frequency and detected clock ratio.
  • Maximum Allowed Frequency: Available only for Intel Pentium III and later CPUs - Katmai and Coppermine core (except CPU ID 0x681) and Pentium 4. This is the highest operating frequency that this CPU is allowed to run by the vendor.
  • L1 Cache: 1st level cache memory size (usually divided into instruction and data parts).
  • L2 Cache: 2nd level cache memory size and type if integrated in the CPU. Can be integrated (Full, Half-speed) or ATC (Advanced Tranfer Cache) for Intel Coppermine and above cores.
  • Instruction TLB: The size and associativity of the Instruction Translation Look-aside Buffer
  • Data TLB: The size and associativity of the Data Translation Look-aside Buffer
  • CPU Flags: Various CPU feature flags. Note, that there are 3 sets of these flags depending on the CPU vendor (Intel, AMD, Cyrix). Althrough most Intel CPUs contain APIC On Chip, this feature is reported as Present only if running in Multi-processor system.
  • P.I.ROM: Program Information ROM. This info is available only on Intel Pentium II/III Xeon Processors. Contains information as max. frequency, voltages, cache size, revisions, S-spec/QDF number ...


Memory Information

Returns information about each memory module installed. There are two types of information, that can be returned:

  1. Information returned from DIMM SPD.
    This is available only for DIMM modules supporting the Serial Presence Detect (SPD) specification. Such modules have a small EPROM memory located at DIMM module, which contains detailed configuration information. This memory is accesible via SMBus (System Management Bus) and can be read only if HWiNFO32 supportes the SMBus Host controller of the mainboard chipset. All later modules are SPD-capable and HWiNFO32 supports the most SMBus controllers.
  2. Information returned from chipset registers.
    This option returns only basic memory information. Please note, that the given Row number doesn't correspond with physical memory organization !
  • Row Size: Size of memory row in MBytes
  • Memory Type: Available are:
    • FPM
    • EDO
    • BEDO
    • SDRAM
    • H/ESDRAM
    • DDR SDRAM
    • VC-SDRAM
    • RDRAM (RIMM, SO-RIMM or Embedded)
  • Error Check/Correction: Available are:
    • None
    • Parity
    • ECC
  • Memory Speed: Operating frequency in MHz
  • Module Manufacturer: May not be available for non-brand memories
  • Module Type: Usually the model number printed on the chip
  • Date Of Manufacture: Please note, that the encoding of this date isn't part of SPD specification and thus it may be misreported if the module manufacturer uses unusual encoding.
  • Voltage: Available are:

    SDRAM:

    • TTL / 5V
    • LVTTL
    • HSTL 1.5V
    • SSTL 3.3V
    • SSTL 2.5V

    RDRAM:

    • 2.5 V
    • 1.8 V
  • SPD Version: Version of SPD specification supported
  • Refresh Rate: Available are:
    • Normal (15.625 us)
    • Reduced 0.25x (3.9 us)
    • Reduced 0.5x (7.8 us)
    • Extended 2x (31.25 us)
    • Extended 4x (62.5 us)
    • Extended 8x (125 us)
  • Supported CAS Latency: Given for supported marginal operating frequencies (e.g. 2 for 100 MHz, 3 for 133 MHz)


Motherboard Information

  • Motherboard Model: The manufacturer and model of the motherboard. This info is reported upon motherboard ID from BIOS in case of Award or AMI BIOS. Otherwise it is read from SMBIOS DMI.
  • Motherboard Chipset: The manufacturer and model of the motherboard's chipset.
  • Motherboard Slots: This information is obtained from SMBIOS DMI.
  • Computer Name: Reported in case of brand PC.
  • Machine Type: Usually IBM PC AT (or compatible).
  • BIOS Manufacturer: The brand name of motherboard's BIOS manufacturer (like AMI, Award, Phoenix...)
  • BIOS Date: Date of manufacture of current latest BIOS version.

  • Plug-and-Play System Nodes: A list of all PnP-capable motherboard devices (nodes) including resources. Maintained by BIOS.
  • Plug-and-Play Capable Devices: A list of all PnP-capable ISA devices.
  • ACPI Devices: A list of ACPI-capable motherboard devices including resources.
  • SMBIOS DMI: System Management BIOS Desktop Management Information. This list is maintained by motherboard's BIOS. HWiNFO32 isn't responsible for the content of this information. If you find any errors, sometimes a BIOS upgrade solves this problem.


Video Information

  • Video Chipset: The video card's chipset manufacturer and model name.
  • Video Memory: The size and type of video memory located on video card. Supported types are:
    • DRAM (Dynamic RAM)
    • VRAM (Video RAM)
    • WRAM (Window RAM)
    • MDRAM (Multibank DRAM - Tseng)
    • SDRAM (Synchronous DRAM)
    • SGRAM (Synchronous Graphics DRAM)
    • DDR SDRAM (Double Data Rate SDRAM)
    • RDRAM (Rambus DRAM)
  • Video Card: The manufacturer and brand name of the video card
  • Video Bus: Type of video card's bus (ISA, PCI, A.G.P., ...)
  • Video RAMDAC: Type of the video card's RAMDAC (Digital-Analog Convertor). Later cards have the RAMDAC integrated into the chip.


Monitor Information

This information is available only when running under Windows 98, 98SE, Me or Windows 2000 and above operating systems. The video card and monitor must also support the VESA DDC (Display Data Channel) specification.

  • Monitor Name: Monitor manufacturer brand and model name.
  • Serial Number: May contain only a part of the real serial number depending on DDC support.
  • Date Of Manufacture: Year and week of manufacture. Sometimes may contain invalid information if non-standard stored.
  • Horizontal/Vertical Frequency: Some monitors report also the max. horizontal and vertical frequency range.
  • Display Type: Supported types:
    • Monochrome/grey scale
    • RGB color
    • Non-RGB color
  • Input Signal: Supported:
    • 0.700 V / 0.300 V (1.000 V p-p)
    • 0.714 V / 0.286 V (1.000 V p-p)
    • 1.000 V / 0.400 V (1.400 V p-p)


Video Information

Drive Information:

  • Floppy Drives: A list of detected floppy drives. More info not available.
  • IDE (ATA/ATAPI) Drives: Contains all detected (E)-IDE drives.
    • General Information: drive channel, controller (IDE/E-IDE), model, revision, serial number and calculated capacity
    • Drive Geometry: cylindes, heads, sectors per track (SpT), bytes per track, bytes per sector, number of ECC bytes, cache buffer size and controller type
      Note, that drives larger tham 8GB report the maximum available number of cylinders (16383), heads (16) and SpT (63).
    • Transfer Mode: Sectors per Interrupt, Max. available PIO (Programmable I/O) transfer mode, Multiword/Singleword/Ultra-DMA transfer mode:
      Transfer mode | Maximum Transfer rate
      PIO 0 | 3.33 MB/s
      PIO 1 | 5.22 MB/s
      PIO 2 | 8.33 MB/s
      PIO 3 | 11.11 MB/s
      PIO 4 | 16.66 MB/s
      DMA 0 | 4.16 MB/s
      DMA 1 | 13.33 MB/s
      DMA 2 | 16.66 MB/s
      Ultra-DMA 0 | 16.66 MB/s
      Ultra-DMA 1 | 25.00 MB/s
      Ultra-DMA 2 | 33.33 MB/s | Ultra-DMA/33
      Ultra-DMA 3 | 44.44 MB/s | Ultra-DMA/44
      Ultra-DMA 4 | 66.66 MB/s | Ultra-DMA/66
      Ultra-DMA 5 | 100.00 MB/s | ATA-100
      Ultra-DMA 6 | 133.33 MB/s | ATA-133
  • SCSI Devices: Contains a list of all detected SCSI devices. This info is available only while running under Windows NT/2000 and above.
    It contains: SCSI port number, bus number, target and LUN ID of the device; device inquiry string (description), device class, supported SCSI version and various device-supported features.


Installation Progress

Troubleshooting/Bug reports

If you experience problems running HWiNFO32 (a crash or lockup) you can try to disable the detection of some components, which may cause problems. Some computers may have problems expecially with:

  • Support of add-on UDMA/66 or ATA-100 controllers or
  • ACPI Enumeration

In this case you should disable the detection/support of those parts: immediately after starting HWiNFO32 push the "Settings" button and the "HWiNFO32 Settings" dialog will appear, where you can select, which of those items will HWiNFO32 detect while start-up.

In case HWiNFO32 does not detect components properly or you still experience problems running it, please contact the author. In order to locate the problem as fast as possible please select "Debug mode" in the above dialog and run the program. Upon completion or reboot (in case it crashes/locks up) please go the the HWiNFO32 installation directory and locate the "HWiNFO32.DBG" file (this is usually C:\Program Files\HWiNFO32\HWiNFO32.DBG, where C: is the drive letter of program's installation). Please report the problem to mailto:martin@hwinfo.com including the description of problem and the HWiNFO32.DBG file.

Please note, that every bug report will be answered and tried to fix.


New Page 1

 ----------  Registration formular for HWiNFO32  ----------

Enter the name [Company - only in case of a Commercial Licence] string of person to be registered to, which will appear in the "Registered to:" box (Max 60 characters).

Name [Company]: ________________________________________________________________

Please select the type of registration. For multiple license write the amount of copies you wish to register.

 Type of registration:

[   ]  Non-Commercial License:

(   )  Single-user (1 Copy)

(   )  Multiple-user: for  ___________ Copies

(   )  UNLIMITED

[   ]  Commercial License:

(   )  Single-user (1 Copy)

(   )  Multiple-user: for  ___________ Copies

(   )  UNLIMITED

Name:  ____________________________________________________________________

Company [optional]:  _________________________________________________________

Street address:  _____________________________________________________________

City: ______________________________________________________________________

ZIP: _________________

Country:  __________________________________________________________________

E-mail: ____________________________________________________________________

--- Select the way of payment ---

For foreign users:

   (   )  I registered on-line at http://www.regsoft.com/

   (   )  I have made a wire bank transfer.

   (   )  I have enclosed a check.

   (   )  I have enclosed the money in bills, at my own risk.

For Slovak/Czech users:

   (   )  Poslal som objednavku na uvedenu adresu a poplatok uhradim po obdrzani faktury.
         Prosim nezabudnite uviest aj ICO/DIC.

   (   )  Poplatok som uhradil postovou poukazkou.

Total Sum:    ____________________

 _____________                                                      _____________________________

         Date                                                                                         Signature